Problem displaying non-keyboard characters using BlueGriffon

Familiar with web-design ? Trouble with images, tables ? Any other queries ?

Moderators: BobCP, agsone, Neil Parks, gregtutor, Lem3

Problem displaying non-keyboard characters using BlueGriffon

Postby MarshallAbrams on Wed Nov 06, 2019 8:35 pm

I'm trying to put non-keyboard characters, such as dagger and curly quotes on my web page. If I insert them in BG as character codes they get converted to the correct graphics. But when I publish the file on the web and view in Chrome, Firefox, or even IE, the characters get replaced by a white question mark on a black diamond. It used to work, but something has changed.
I got the idea of forcing BF to keep the numeric or alpha code, but I can't figure out how. Suggestions?
MarshallAbrams
 
Posts: 19
Joined: Thu Jan 01, 2009 7:11 pm
Location: Silver Spring, MD

Re: Problem displaying non-keyboard characters using BlueGriffon

Postby gregtutor on Thu Nov 07, 2019 12:35 pm

Sounds like a character set issue and servers can be fussy, while BG can be forgiving.

I suspect the change you experience depends on how you created the page.

If you just click on the "Create new page" button then you get the line:

Code: Select all
<meta content="text/html; charset=windows-1252" http-equiv="content-type">

in your code.

However, if you use the drop-down and select "more options" the page will default to:

Code: Select all
<meta content="text/html; charset=utf-8" http-equiv="content-type">

as will the "New Wizard" option on the file menu.

Try changing the line to the charset=utf-8" version. It's more likely to work with unusual symbols.
Last edited by gregtutor on Thu Nov 07, 2019 12:35 pm, edited 1 time in total.
Greg Chapman
http://www.gregtutor.co.uk
Helping new users of KompoZer - but using BlueGriffon
gregtutor
Moderator
 
Posts: 3790
Joined: Wed Jun 20, 2007 8:25 am
Location: The Norfolk Broads, UK
Country: England (en)


Return to General Q & A


Who is online

Users browsing this forum: Google [Bot] and 0 guests